apache/seatunnel
Documented errors, page 13 of 22. Back to apache/seatunnel
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Table name duplicate | exception | error | sql-config, duplicate-definition, config-validation, java |
| Unknown format type: | exception | error | aerospike, enum, config, validation |
| Unsupported handleSplitRequest | exception | error | clickhouse, split-enumerator, unsupported-operation, protocol |
| Can not find any plugin(source/sink/transform) in the dir | exception | error | java, plugin-discovery, io, configuration |
CommonErrorCode.UNSUPPORTED_DATA_TYPE Unsupported format | error_code | error | pulsar, serialization, format |
| currentThread already be interrupted, skip trigger… | console | warning | checkpoint, interrupt, zeta, coordinator |
| Database already exists in catalog | exception | error | paimon, catalog, database-exists |
| Failed to close Neo4j source reader. | exception | error | neo4j, resource-cleanup, io |
| Failed to convert value in IN clause | exception | error | sql, paimon, type-conversion, in-clause |
| Failed to delete log file | console | warning | file-deletion, io, logs, cleanup |
| max_queue_size must be greater than 0, got | validation | error | mqtt, queue, validation, config |
| MySQL-CDC diagnostic: SHOW MASTER STATUS returned empty… | console | warning | mysql, cdc, diagnostics, binlog, master-status |
| start_timestamp must be less than end_timestamp | validation | error | hbase, validation, timestamp, config |
| The mode is not supported. | exception | error | cdc, startup-mode, enum |
| the uri of jar illegal | exception | error | java, classpath, url, env-config |
| Value is not a BSON date or timestamp | exception | error | java, documentdb, datetime, type-mismatch |
CLOSE_CLIENT_FAILED Close Firestore client failed. | error_code | warning | firestore, sink, resource-cleanup |
| Condition operator must not be null | validation | error | excel, configuration, validation, poi |
| Database does not exist in catalog | exception | error | catalog, hudi, not-found, namespace |
| DataTypeChanger not reset | exception | error | schema-change, lifecycle, initialization, cdc |
| Duplicate SNMP source OID | validation | error | config, snmp, oid, validation |
| Failed to close failure-data writer. cause= | console | warning | hugegraph, io, resource-cleanup, file-write |
| Failed to close flush timer for task | console | warning | flush-timer, shutdown, source, non-fatal |
| Failed to convert row to JSON | exception | error | databend, json, serialization, sink |
| Failed to start Oracle LogMiner session, retrying... | console | warning | oracle-cdc, logminer, ora-01291, archive-logs, retry |
| Invalid user/password specified | exception | error | ftp, authentication, config, filesystem |
| List type requires List value, got | validation | error | lance, arrow, type-mismatch, list, validation |
OPERATION_NOT_SUPPORTED kafka_headers_fields is not supported with NATIVE format. Please use JSON… | error_code | error | kafka, config-validation, native-format, headers |
SCHEMA_CHANGE_FAILED Failed to schemaChange | error_code | error | doris, schema-change, ddl |
| there should always be a valid xlog position | exception | error | cdc, postgres, wal, invariant |
| Type ' ' has a maximum precision of 536870911 in Vertica… | console | warning | jdbc, vertica, precision, string-type |
| Unable to convert to LocalTime from unexpected value '' of… | exception | error | java, cdc, time-conversion, unsupported-type |
| Unknown checkpoint type: | exception | error | enum, checkpoint, zeta-engine |
| Unknown table change type: | exception | error | cdc, debezium, deserialization, enum |
| Unknown TaskGroup State | exception | error | zeta-engine, task-group, switch-default, state-machine |
| Utilization values must be between 0 and 1 | validation | error | validation, load-balancer, metrics |
| Append only table currently do not support dynamic bucket | console | info | paimon, bucketing, configuration |
| Can't create JdbcDialect without compatible mode for… | exception | error | jdbc, oceanbase, dialect, missing-config |
| DocumentBulk is already full | exception | error | mongodb, internal-error, buffer-overflow |
| Python script exited before reading its first stdin line… | exception | error | process, broken-pipe, python, startup |
| SQL execute error, sql | console | warning | cdc, oracle, sql, table-discovery, swallowed-exception |
| The GCS bucket must be a bucket URI such as… | validation | error | gcs, config-validation, bucket |
WRITE_RECORDS_FAILED Flush failed during close | error_code | error | flush, close, couchbase |
BUILD_CLIENT_FAILED Failed to establish initial connection | error_code | error | hugegraph, connection, client-init |
CATALOG_TABLE_FAILED tableSchema is null | error_code | error | assert, catalog-table, null-schema |
DATA_DESERIALIZE_FAILED Deserialize this data | exception | error | deserialization, text-file, data-quality |
| Error scanning data from region. | exception | error | tikv, scan, rpc, region-cache, wrapped-exception |
| Oracle-CDC specific startup mode uses… | validation | error | oracle-cdc, startup-mode, offset, config-validation |
| Snapshotting of table failed | exception | error | db2, cdc, snapshot, sql |
| startup.specific-offset.scn is only supported when… | validation | error | oracle-cdc, startup-mode, config-validation |
| Table schema is null or empty. DescribeTable returned: | exception | error | lance, catalog, empty-schema |
| Table 'TablePath ' does not exist in catalog 'null | exception | error | jdbc, catalog, table-not-exist, tablepath |
| upsert data failed, retry in smaller chunks | console | warning | milvus, rate-limit, retry, backpressure |
| conditional option rule for | validation | error | |
| DatabaseNotExistException: catalogName, databaseName | error_code | error | databend, catalog, database-not-exist, metadata |
| Error closing potentially broken client | console | warning | hugegraph, connection, resource-cleanup, client |
| Failed to config. Please check your configuration. | validation | error | config, encryption, decryption |
| MQTT QoS must be 0 (at-most-once) or 1 (at-least-once)… | validation | error | mqtt, config-validation, qos |
| not supported create new Offset by committed offset. | exception | error | cdc, offset, unsupported-operation |
| Source path does not exist | exception | error | ftp, file-not-found, rename |
| The file does not support the compressed file reading | exception | error | file, archive, compression, unsupported-operation |
| Transform/Sink don't support processing data with two… | validation | error | job-parsing, schema-mismatch, data-types, dag-construction |
| Unsafe invoke, the current thread | exception | error | concurrency, locking, fetcher, reentrantlock |
| Unsupported plugin type | validation | error | rest-api, plugin, unsupported-operation, enum |
| Cannot build a NebulaGraph request for an empty batch. | exception | error | java, nebulagraph, empty-batch |
| check connectivity failed, | exception | error | iceberg, kerberos, hadoop, authentication |
| Edge transport IO failure, will reconnect. batchId= | console | warning | network, socket, reconnect, io |
| Failed to resolve log file path | console | warning | rest, logging, file-io, servlet |
FIELD_NOT_IN_TABLE Field " + field + " does not exist in table " + pluginConfig.get(TABLE) | error_code | error | cassandra, schema, validation, configuration |
| Invalid Deep Lake workspace | exception | error | deeplake, url-encoding, jvm |
| Invalid metricType ' ' for column ' '. Valid values are | exception | error | vector-index, enum, validation |
JdbcConnectorErrorCode.DONT_SUPPORT_SINK The Presto jdbc connector don't support sink | error_code | error | jdbc, presto, sink, unsupported |
| shard cursor error | exception | error | sls, cursor, source-split |
| Skipping checkpoint transactions that are absent from the… | console | warning | xa, recovery, checkpoint |
| String range left boundary | exception | error | jdbc, splitter, string-range, argument-order |
| The decimal column type decimal( , ) is out of range, which… | console | warning | jdbc, oracle, decimal, scale |
| The ' ' option is not configured, please configure it. | validation | error | java, job-config, missing-option, plugin-name |
| Unsupported convert to byte[], typeDefine | exception | error | type-mismatch, bytes-conversion, seatunnel-api |
| Close scanner from failed. | console | warning | thrift, doris, rpc, cleanup, suppressed-exception |
| create table statement execute failed | exception | error | |
| Failed to convert timestamp to SCN | exception | error | oracle-cdc, scn, timestamp, sql |
| Failed to parse PostgreSQL timestamptz string | exception | error | jdbc, postgresql, timestamp, date-parsing |
| Interrupted while waiting for Kudu client executor to… | console | warning | kudu, interrupt, executor, shutdown |
LIST_PARTITIONS_FAILED Failed to show partitions: | error_code | error | milvus, source, split-enumeration, rpc-error |
| nodes[ ]: port is out of range [ , ] | validation | error | redis, config-validation, port-range |
| Please use the new key | console | warning | configuration, deprecation, options |
| Produce too many splits. | exception | error | paimon, source, splits, overflow |
| Proxy Connection is null. | exception | error | jdbc, connection-pool, proxy, copy |
RedisErrorCode-03 Failed to get the write response | error_code | error | redis, pipeline, write, jedis |
| Rejected edge collector from | console | warning | tcp, concurrency, connection-rejected |
SEND_MESSAGE_FAILED Cannot send AMQ message | error_code | error | activemq, jms, send, network |
SHOULD_NEVER_HAPPEN No Doris stream load node initialized. | error_code | critical | doris, stream-load, connectivity |
| The length of clob type | console | warning | jdbc, db2, clob, length-limit |
| Avro format doesn't support non-string as key type of map… | exception | error | hudi, avro, map-type, unsupported-type, type-mapping |
DECIMAL_PRECISION_INCOMPATIBLE ` ` field value is: , except field schema of sink is , but the field in sink… | error_code | error | paimon, decimal, schema-mismatch |
| Either metastore_uri or hive.metastore.client.factory.class… | validation | error | hive-metastore, config, missing-uri |
| Failed dropping table | exception | error | jdbc, catalog, sql, drop-table |
| Failed to close Google Pub/Sub subscriber | exception | warning | pubsub, shutdown, resource-cleanup |
| Get connection failed after retry times | exception | critical | jdbc, connection, retry-exhausted, database |
| intervalMs must be positive, got | validation | error | zeta-engine, timer, validation, illegal-argument |