apache/seatunnel
Documented errors, page 12 of 22. Back to apache/seatunnel
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Table . not found in table list of job configuration. | exception | error | table-not-found, state-mismatch, checkpoint, clickhouse, reader |
| The value of the ' ' option of the ( and ) plugins is both… | validation | error | java, job-config, dag, naming-conflict |
| Unsupported data type | exception | error | milvus, schema, catalog, unsupported-type |
| Unsupported like keyword: | exception | error | sql, expression, iceberg |
| Write operations require --yes (or use --dry-run) | validation | error | cli, safety-guard, write-operations, confirmation |
CREATE_INDEX_ERROR indexType is required for vector index on column | error_code | error | milvus, catalog, index, vector, config |
| Failed to get response from Doris | console | error | doris, http, rest, fe, authentication |
| Failed to login user from keytab | exception | error | kerberos, authentication, hdfs, keytab |
| Flush data into clickhouse file error | exception | error | clickhouse, flush, io |
| Ignoring attempted add of a metric due to being null for… | console | warning | metrics, null-check, observability |
| Integer value is out of range | exception | error | serialization, type-conversion, numeric-overflow |
| Invalid hiveSitePath | console | warning | hive, configuration, url, hive-site |
KERBEROS_AUTHORIZED_FAILED Kerberos Authorized Fail! | error_code | error | kerberos, authentication, hadoop, hudi |
| No actions define in the job. Cannot execute. | exception | error | dag, job-config, zeta-engine |
| Options 'credentials_path' and 'emulator_host' cannot be… | validation | error | pubsub, sink, config, validation |
| Unsupported type | exception | error | java, unsupported-type, factory, imap-storage |
| Edge socket receiver executor did not terminate within… | console | warning | lifecycle, shutdown, timeout, thread |
| Exceeded maxBatchSendAttempts= | exception | error | retry, timeout, backpressure, socket |
| Failed to close during initialization cleanup. | console | info | io, stream-load, cleanup, doris |
| Failed to close file discovery resources for plugin | console | warning | file, hadoop, resource-leak |
| Failed to get connection, interrupted while doing another… | exception | error | jdbc, connection, retry, interrupted, cancellation |
| Failed to get HTTP port from member | console | warning | network, rest-api, hazelcast, cluster, http-port |
IotdbConnectorErrorCode.CLOSE_CLIENT_FAILED Close IoTDB client failed. | error_code | warning | iotdb, session-close, sink, network |
| Logout failed while disconnecting, error code - | console | warning | ftp, logout, connection-close, cleanup |
| Multiple input tables are not supported in flink plugin | validation | error | flink, multi-table, unsupported-operation |
| NebulaGraph write request failed. | exception | error | nebulagraph, write-failed, io, unexpected-exception |
| Python source thread did not finish within ms while… | console | warning | python, thread-leak, shutdown |
READER_OPERATION_FAILED Failed to read Neo4j table | error_code | error | neo4j, read-failure, cypher |
| `table_path` and `sql` parameter cannot be both empty. | validation | error | clickhouse, config, validation, table-list |
| The data does not match the configured schema information… | exception | error | text-format, serialization, schema-mismatch |
| Unexpected error while connecting to MySQL and looking at… | exception | error | mysql, jdbc, gtid, cdc, sql |
| checkpoint restore requires a terminal source job… | exception | error | checkpoint-restore, job-status, invalid-state, zeta-engine |
| Collect worker resource snapshot failed | console | warning | diagnostics, workers, resource-manager, rpc |
| connectorIdentify is not supported | exception | error | spi, convertor, unsupported-identifier |
| Database already exists in catalog hive | exception | error | hive, catalog, database-exists |
| Failed to broadcast FlushSignal from task | console | warning | flush, checkpoint, source, timer |
| Invalid filter condition: | exception | error | argument-parsing, filters, kudu |
JdbcConnectorErrorCode.DATA_TYPE_CAST_FAILED error field | error_code | error | jdbc, oceanbase, type-cast, data-conversion |
| No table filters found for filtered publication | exception | error | cdc, postgres, publication, table-filter, config |
| ' ' source don't support off-line job. | validation | error | job-mode, source-connector, batch, streaming, config |
| The size of collection is not equal to the size of row type | exception | error | schema-mismatch, row-conversion, seatunnel-api |
| Unsupported restored PendingSplitsState: " + checkpointState | exception | error | cdc, checkpoint, restore, state-compatibility |
| Both channel and connection closing failed. Logging channel… | console | warning | rabbitmq, shutdown, network |
| Cannot convert timestamp: , type: | exception | error | iceberg, type-conversion, timestamp, sink |
| columnDefine size not match | exception | error | java, schema, data-conversion |
| Currently, only support one split key | exception | error | jdbc, splitter, composite-key, unsupported |
| Database processing error | exception | error | postgres, cdc, database, startup |
DROP_INDEX_FAILED DELETE / response null | error_code | error | easysearch, rest-client, network, index-management |
| Error to discover tables | exception | error | mysql, jdbc, table-discovery, privileges |
| Failed EXECUTE SQL in catalog | exception | error | clickhouse, catalog, sql, ddl |
| Failed to get primary key for table | console | warning | clickhouse, jdbc, metadata, primary-key |
| Invalid option rules request, type | console | warning | rest, servlet, validation, option-rules |
| Retention scan failed: backupPath= | console | error | |
| Failed to open MongoDB Catalog | exception | error | mongodb, catalog, connection, initialization |
| File [ ] has fewer lines than expected to skip. | exception | error | csv, config-validation, skip-headers |
| Fluss source does not support partitioned tables yet | exception | error | unsupported-feature, fluss, partitioned-table, source |
| Generic exception wrapped (open failed) | exception | error | sftp, io, open |
| Gravitino URI is required. Please configure… | validation | error | |
| Interrupted during retry | exception | warning | java, dynamodb, interrupt, retry |
INVALID_ROW Input row arity does not match the configured schema arity | error_code | error | snmp, sink, schema, row-validation |
| nodes[ ]: must be in 'host:port' format, got | validation | error | redis, config, validation, format |
| SHA-256 is not supported by this JVM | exception | error | jvm, crypto, hashing |
| Source offset '" + key + "' parameter value " + obj + "… | exception | error | cdc, offset, parsing, configuration |
| tables_configs[ ]: 'query' must be configured and non-blank | validation | error | neo4j, config-validation, missing-query |
| All candidate sink tables were skipped in Flink starter. | exception | critical | flink, sink, multi-table |
COMMON-16 ' ' unsupported convert type ' ' of ' ' to SeaTunnel data type. | error_code | error | hive, type-conversion, schema |
| Failed to serialize checkpoint data, state | exception | error | serialization, checkpoint-storage, hdfs |
| MySQL-CDC diagnostic: variable | console | info | mysql, cdc, diagnostics, binlog, retention |
| No LSN found for timestamp | exception | error | sqlserver, cdc, lsn, timestamp |
| Path traversal attempt blocked - Requested | console | warning | security, rest-api, path-traversal |
| Rollback statements cannot be handled without binlog… | console | warning | mysql, cdc, binlog, transaction |
| ' ' duplicate in option options. | validation | error | |
| SplitFetcher thread received unexpected exception while… | exception | error | fetcher, split-reader, runtime-exception, polling |
| transport.auth-type must be "token" when set; "none" is not… | validation | error | config, authentication, validation |
| Unsupported to derive Schema for type | exception | error | hudi, avro, schema, unsupported-type, type-mapping |
WRITER_CLOSE_FAILED Failed to close writer | error_code | warning | aerospike, close, cleanup, sink |
| can't apply resource request | exception | error | zeta-engine, resource-allocation, pre-check |
| CorrelationId is missing but required, rejecting message tag | console | warning | rabbitmq, message-validation, ack |
| Could not find field with name | exception | error | json, deserialization, schema, missing-field |
| Failed to initialize Google Service Account credentials | exception | error | firebase, gcp, authentication, io |
| input.multiline.max-lines must be >= 1 when set | validation | error | config, validation, file-collect |
PACKET_UNSUPPORTED_ENCRYPTION Unsupported packet encryption type: | error_code | error | encryption, deserialization, connector-edge-socket |
SEND_EMAIL_FAILED Send email failed | error_code | error | email, smtp, network, sink |
| Unable to create a sink for identifier 'MultiTableSink'. | exception | error | factory, multi-table-sink, wrapper |
| Unsupported AlterTableColumnEvent | exception | error | jdbc, oracle, schema-evolution, unsupported-event |
UNSUPPORTED_AUTH_TYPE Unsupported authentication type | error_code | error | elasticsearch, authentication, configuration, enum |
| Cannot convert timestamptz: , type: | exception | error | iceberg, type-conversion, timestamp, timestamptz |
| Could not load truststore | exception | error | mysql, cdc, ssl, tls, truststore |
| Database not empty, can't drop it. | exception | error | hudi, catalog, database-drop, precondition |
| Deploy mode not supported | validation | error | spark, deploy-mode, cli-argument |
| Failed to close HugeGraph sink writer | exception | error | sink, close, ioexception, resource-cleanup |
| Failed to list files from names | exception | error | hdfs, io, list, storage |
| Failed to load AmazonDocumentDB TLS CA bundle: | validation | error | tls, certificates, security |
| Failed to parse select columns: | exception | error | sql, parser, iceberg |
| Failed to write python.script.config | exception | error | process, ipc, io |
| Infinite Decimal128 values are not supported | exception | error | serialization, decimal128, validation |
| Invalid host specified | exception | error | ftp, config, filesystem, uri |
| Invalid JDBC URL format | validation | error | jdbc, config-validation, url |
| : : : :fail | exception | error | sls, cursor, config |
| Sparse vector index cannot be negative | validation | error | vector, index, validation |