lima-vm/lima
Documented errors, page 2 of 5. Back to lima-vm/lima
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| failed to parse rsync version | console | error | rsync, version-parsing, cli |
| symlink target %#q in %#q escapes the repository | validation | error | path-traversal, security, symlink |
| failed to fetch file | exception | error | network, http, github |
| failed to resolve vm for %#q | console | error | restart, vm-type, config |
| instance %#q is stopped, run `limactl start | console | error | cli, instance-lifecycle, lima |
| path is empty | validation | error | mcp, path, validation, go |
| failed to write driver PID file | exception | error | filesystem, external-driver, pid-file, startup |
| failed to create the synced workdir in guest instance | console | error | cli, limactl, ssh, rsync, sync |
| failed to get hostname | panic | critical | hostname, machine-id, panic, linux |
| failed to run attach disk %#q, in use by instance %#q | exception | error | krunkit, disks, lock, macos, concurrency |
| identifier %#q greater than maximum length | validation | error | validation, identifier, lima |
| vz driver state stopped | error_code | error | vz-driver, vm-lifecycle, shutdown |
| expected the depth of the converted host working directory… | console | error | cli, limactl, rsync, path-depth, windows, cygpath |
| failed to delete instance %#q | console | error | instance, delete, limactl |
| failed to start less | console | error | pager, exec, less, environment |
| failed to sync back the changes from guest instance to host… | console | error | rsync, ssh, diff, file-sync |
| reading omap child node | exception | critical | apfs, btree, io-error |
| expected *net.TCPAddr, got | exception | error | network, freeport, type-assertion |
| provision mode %#q is not supported on Windows VM | validation | error | lima, limayaml, windows, provision |
| inode has ownership : , expected : from noowners mount | exception | warning | apfs, inode, ownership, noowners, chown |
| instance not registered | error_code | error | lima, mcp, toolset, instance-registration |
| socket_vmnet is not installed | exception | error | krunkit, network, socket-vmnet, macos, bridged |
| failed to run diff command | console | error | diff, permissions, preview |
| failed to sync back the changes from guest instance to host | console | error | rsync, ssh, data-loss, file-sync |
| field `probe[ ].file.url` must be empty during validation… | validation | error | config-validation, probe, lima-yaml |
| don't know how to interpret %#q as a template locator | console | error | cli, template, locator |
| expected element, got < > | exception | error | plist, xml, dict, schema |
| failed to mount fstab entry | exception | error | macos, cloud-init, mount, virtiofs |
| field `provision[ ].path` must not be empty when mode is %#q | validation | error | lima, limayaml, validation, provision, missing-field |
| currently Windows guest OS is only supported on QEMU | validation | error | config-validation, windows-guest, vz |
| expected status of instance %#q to be %#q, got %#q | error_code | error | lima, mcp, instance-lifecycle, status-check |
| failed to generate password | exception | error | windows, password, crypto |
| hostagent (%#q) did not start up in | exception | error | hostagent, timeout, pidfile |
| %s: %w | exception | error | windows, hcs, async-operation, syscall |
| instance %#q directory %#q exists but its %#q could not be… | console | warning | instance, delete, concurrency, filesystem |
| krunkit CLI not found in PATH. Install it via: brew tap… | validation | error | macos, krunkit, missing-binary, path |
| degraded, status=%+v | exception | warning | hostagent, degraded, port-forwarding, file-sharing |
| failed to get ISO label | exception | error | windows, iso, file-io |
| failed to unmarshal %#q as %T | exception | error | json, unmarshal, events, parsing |
| unexpected plist format: missing root dict | exception | error | macos, plist, schema, parsing |
| failed to enable SSHD | exception | error | guestagent, macos, cloud-init, sshd |
| failed to remove stale raw image | exception | error | go, filesystem, cache, permissions |
| stdout=%#q, stderr=%#q | exception | error | ssh, forward-agent, guest, script |
| vmType %#q is not a registered driver | exception | error | configuration, validation, vmtype |
| failed to open TUI: ; preserving guest synced workdir at | console | error | tui, terminal, interactive |
| failed to run : (out=%#q) | exception | error | macos, qemu, codesign, entitlement |
| instance %#q not found | console | error | instance, limactl, not-found |
| field `provision[ ].script` must not be empty | validation | error | lima, config-validation, provision, script |
| field ` .guest` must be an absolute path, but is %#q | validation | error | lima, config-validation, copytohost, paths |
| identifier %#q must match | validation | error | validation, identifier, regexp |
| inode value exceeds block boundary | exception | error | apfs, inode, bounds-check, block-size, chown |
| network mode %#q requires specifying gateway | console | error | network, cli, missing-flag |
| no volume with role %#x found | exception | error | apfs, configuration, volume-role |
| field `probe[ ].mode` can only be %#q | validation | error | config-validation, port-forward, network |
| unable to connect to guest agent via vsock port 2222 | exception | error | vsock, vz-driver, guestagent, macos |
| inode has mismatched private_id | exception | error | apfs, inode, private-id, integrity, chown |
| omap node | exception | error | apfs, btree, corruption |
| filesystem B-tree node | exception | error | apfs, b-tree, node-type, validation, corruption |
| no sudoers file defined in %#q | console | error | cli, macos, sudoers, networks-config |
| unknown or unsupported VM type | exception | error | configuration, driver-registry, vmtype |
| error running wslCommand that executes boot.sh | exception | error | wsl2, provisioning, guest-startup |
| failed to remove socket %#q | exception | error | krunkit, filesystem, socket, cleanup |
| failed to replace original with raw image | exception | error | go, filesystem, cache, race-condition |
| failed to unregister %#q | exception | error | instance-delete, unregister, driver |
| field `provision[ ].content` can only be set when mode is… | validation | error | lima, config-validation, provision, mode-mismatch |
| failed to convert extra disk %#q to raw | exception | error | krunkit, disks, raw-image, conversion, macos |
| failed to run load disk %#q | error_code | error | disk, disk-store, vz-driver |
| unimplemented | exception | warning | windows, hcs, unimplemented, snapshots |
| read block 0 | exception | error | apfs, io, disk-image, corruption |
| reading volume omap | exception | critical | apfs, disk-image, corruption |
| daemon %#q (path=%#q) is not available | error_code | error | network, daemon, socket-vmnet, installation, go |
| instance %#q does not exist, run `limactl create | console | error | cli, tunnel, instance |
| usernet unable to resolve IP for SSH forwarding | error_code | error | network, usernet, dhcp, timeout, ssh-forwarding |
| skipped to download | error_code | info | download, arch-mismatch, sentinel-error |
| unsupported plist type | exception | error | plist, xml, schema, unsupported-element |
| cannot convert %#q to an MSYS-style path: input is not an… | validation | error | windows, fsutil, path-conversion, validation |
| directory entry %#q not found | exception | error | apfs, b-tree, not-found, directory, path-resolution |
| field `provision[ ].path` must be an absolute path | validation | error | lima, limayaml, validation, path, provision |
| invalid port forward format %#q, expected HOST:GUEST | validation | error | port-forward, cli, argument-parsing, validation |
| unexpected daemon %#q | panic | critical | network, daemon, panic, socket-vmnet, go |
| disk shrinking is not supported | exception | error | disk, resize, validation |
| failed to install macOS | exception | error | macos, vz, installer, virtualization-framework |
| nested virtualization requires macOS 15 or newer | validation | error | vz-driver, nested-virtualization, macos-version |
| failed to remove a directory %#q | console | error | disk, cleanup, permissions |
| failed to symlink %#q to %#q | exception | error | symlink, disk-layout, migration, instance-storage |
| field ` .hostSocket` must be an absolute path, but is %#q | validation | error | lima, port-forwarding, unix-socket, config-validation |
| no SSH key was found, run `ssh-keygen` | exception | error | ssh, cidata, cloud-init, configuration |
| pattern %#q contains invalid character %#q at position | validation | error | validation, glob-pattern, environment |
| failed to inspect status | console | error | lima, driver, vm-status |
| network mode %#q requires specifying interface | validation | error | network, cli, gateway |
| no machine-id found, tried | exception | warning | machine-id, linux, filesystem |
| resolving child OID | exception | error | apfs, omap, b-tree, oid-resolution, snapshot |
| unexpected answer | console | error | cli, interactive-tui, limactl-start |
| failed to convert output from UTF16 when running command | exception | error | windows, wsl, encoding, utf16 |
| field `provision[ ].overwrite` can only be set when mode is… | validation | error | lima, config-validation, provision, mode-mismatch |
| network %#q already exists | validation | error | network, cli, config |
| unsupported disk format for macOS guest | validation | error | macos, vz, disk-image, config-validation |
| unsupported filesystem type %#q for fstab entry | validation | error | macos, cloud-init, mount, virtiofs, unsupported |
| daemon %#q not defined | error_code | error | network, daemon, config, go |
| errors inspecting instance: %+v | console | error | cli, instance-inspection, config-validation |