lima-vm/lima
Documented errors, page 4 of 5. Back to lima-vm/lima
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| cannot use both --tty and --yes flags at the same time | validation | error | cli, flags, interactive |
| network %#q is not defined | error_code | error | network, config, validation, go |
| failed to create symlink from %#q to %#q | exception | error | macos, cloud-init, symlink, virtiofs, filesystem |
| failed to run : expected `yes`, got %#q | exception | error | kubernetes, kubectl, guestagent, output-validation |
| failed to write raw digest file | exception | error | go, filesystem, cache, disk-space |
| field `provision[ ].content` must not be empty when mode is… | validation | error | lima, limayaml, validation, provision, missing-field |
| function takes at least one string argument | validation | error | templates, argument-validation, lima-yaml |
| field `disk` has an invalid value | validation | error | lima, config-validation, disk-size |
| unexpected architecture: %#q | exception | error | qemu, firmware, architecture, config |
| failed to request start via autostart manager | exception | error | autostart, systemd, launchd, startup |
| failed to create a temporary file for signing QEMU binary | exception | error | macos, qemu, codesign, tempfile, filesystem |
| failed to mount %#q on %#q | exception | error | macos, mount, filesystem, subprocess |
| failed to rename raw digest file | exception | error | go, filesystem, cache, race-condition |
| failed to start the instance %#q via systemctl | exception | error | systemd, autostart, linux, vm-start |
| field `mountType` must be %#q or %#q for krunkit driver… | validation | error | krunkit, config-validation, mount |
| port not found in %#q | console | warning | lima, ssh, config, port |
| the file argument can be specified only for --check mode | console | error | cli, macos, sudoers, argument-validation |
| failed to convert image to raw | exception | error | downloader, image-conversion, raw-format, cache |
| failed to kill process with pid | exception | error | network, usernet, process-kill, unix |
| invalid pseudo tag for virtiofs: %#q | exception | error | macos, cloud-init, virtiofs, validation, path |
| nested virtualization is not supported on this device | validation | error | vz-driver, nested-virtualization, hardware |
| : variant mismatch (expected , got ) | exception | warning | images, variant, flag |
| cannot determine size of %#q | console | error | qcow2, disk, corrupt-image |
| failed to remove %#q | exception | error | instance-delete, filesystem-permission, cleanup |
| failed to set timezone | exception | error | macos, cloud-init, timezone, command-failed |
| field ` .host` must be an absolute path, but is %#q | validation | error | lima, config-validation, copytohost, paths |
| vmOpts.vz.diskImageFormat=%#q requires macOS 26 or higher… | validation | error | macos, vz, version-check, disk-image |
| failed to create pipe for less | console | error | pager, exec, file-descriptors |
| failed to marshal template %#q again after filling defaults | console | error | cli, template, marshal, yaml |
| failed to stop the instance %#q via systemctl | exception | error | systemd, autostart, linux, vm-stop |
| inspect status command failed | exception | error | external-driver, process-exit, stderr |
| unsupported image type for | validation | error | wsl2, image-format, config-validation |
| expected *net.UDPAddr, got | exception | error | network, udp, freeport, type-assertion |
| failed to find data slice in attached disk | exception | error | guestpatch, macos, disk, asif |
| field `os` must be one of %#q; got %#q | validation | error | lima, os-field, config-validation |
| invalid disk size %#q | validation | error | macos, vz, disk-size, config-validation |
| screenshot capture returned no data; GUI window may not be… | error_code | error | screenshot, vz-driver, macos-permissions |
| (set video.display to "default" or "vz" to enable… | error_code | error | screenshot, vz-driver, gui |
| failed to parse CIDR %#q | console | error | network, cidr, validation |
| failed to validate YAML file %#q | console | error | cli, yaml, validation, limayaml |
| instance not found | console | error | instance, cli, not-found |
| expected tag | console | error | snapshot, cli, missing-flag |
| failed to create hard link from %#q to %#q | error_code | error | filesystem, ipsw, macos-guest, vz |
| failed to disable the autostart entry for instance %#q | exception | error | autostart, systemd, launchd, linux |
| failed to read %#q content | exception | error | network, io, http |
| failed to the autostart entry for instance %#q | console | error | autostart, systemd, permissions |
| binary %#q seems signed but lacking the… | exception | error | macos, qemu, codesign, entitlement |
| networks.yaml: %#q (`paths.socketVMNet`) has to be installed | validation | error | config, networks-yaml, macos, socket-vmnet, missing-dependency |
| vz timeout while waiting for stop status | exception | error | timeout, vz-driver, shutdown, macos |
| failed to create ASIF image %#q | exception | error | macos, diskutil, disk-image, asif |
| unexpected audio device %#q | validation | error | audio, config-validation, vz |
| can't read %#q: : (Hint: ) | error_code | error | network, sudo, sudoers-file, permissions |
| cannot execute template %#q | console | error | lima, go-templates, format |
| cannot use `--workdir` and `--sync` at the same time | validation | error | cli, limactl, flags-conflict, sync, workdir |
| failed to convert to raw | exception | error | downloader, image-conversion, raw-format, disk-space |
| field Home must be set | validation | error | validation, home-dir, cidata |
| field `provision[ ].owner` can only be set when mode is %#q | validation | error | lima, config-validation, provision, mode-mismatch |
| invalid real value | exception | error | plist, float, parsing, strconv |
| failed to convert extra disk %#q to a raw disk | error_code | error | disk, conversion, vz-driver |
| failed to enable LaunchDaemon | console | error | macos, launchd, sudo, daemon |
| failed to install plist to | console | error | macos, launchd, sudo, permissions |
| failed to write temp plist | console | error | macos, launchd, filesystem, disk-full |
| field `containerd.archives` must be provided | validation | error | config-validation, containerd, lima-yaml |
| cannot add global fields to instance data | console | error | lima, go-templates, internal |
| failed to get hostname for instance %#q, err | exception | error | wsl2, ssh-address, networking |
| failed to read instance state for instance %#q because… | exception | error | wsl2, kernel-missing, per-user-install |
| timesync: not supported on this platform | exception | info | guestagent, timesync, platform-compat |
| failed to delete disk %#q | console | error | disk, delete, filesystem |
| invalid IP address | console | error | network, ip-validation, gateway |
| directory is unknown for the instance %#q | exception | error | ssh, config, instance-directory |
| failed to get Info from %#q | console | error | lima, hostagent, grpc, timeout |
| field `mounts[ ].location` refers to a non-directory path… | validation | error | lima, config-validation, mounts, filesystem |
| field `vmOpts.qemu.minimumVersion` must be a semvar value… | validation | error | qemu, config, semver, validation |
| instance is not running (status: ) | console | error | screenshot, instance-status, not-running |
| mount type %#q is explicitly unsupported | validation | error | qemu, mount, config-conflict, validation |
| no images are configured (did you set --image-variant or… | validation | error | images, variant, configuration |
| failed to open raw tmp file | exception | error | downloader, file-io, permissions, cache |
| failed to read instance state for instance %#q, try running… | exception | error | wsl2, state-detection, empty-output |
| failed to run `wsl.exe --distribution | exception | error | wsl2, windows, wsl-exe, vm-start |
| unsupported image type for | validation | error | wsl2, image-format, config-validation |
| expected status %#q, got %#q | exception | error | instance-delete, instance-status, lifecycle |
| failed to remove | console | error | macos, launchd, sudo, permissions |
| field `mountType` must be one of | validation | error | qemu, mount, linux, validation |
| in use by instance %#q | console | error | disk, locking, resource-conflict |
| cannot enable nested virtualization | error_code | error | vz-driver, nested-virtualization, macos |
| failed to open netlink connection | exception | error | guestagent, netlink, linux, sockets |
| instance is protected to prohibit accidental removal (Hint… | exception | error | instance-delete, protected-instance, safety-guard |
| no RequestStart function available | exception | error | autostart, api-misuse, configuration |
| failed to delete driver instance | exception | error | driver, instance-delete, resource-cleanup |
| failed to rename ASIF image from %#q to %#q | exception | error | macos, file-rename, disk-image, asif |
| could not execute editor %#q for a file %#q | exception | error | editor, subprocess, environment |
| failed to check autostart registration | exception | error | autostart, hostagent, systemd |
| field `memory` has an invalid value | validation | error | lima, memory, units, parsing |
| sudoers command is only supported on macOS right now | console | error | cli, platform-limitation, macos, sudoers |
| failed to attach disk %#q | error_code | error | disk, locking, vz-driver |
| error running wsl keepAlive command | exception | error | wsl2, process-lifecycle, keepalive |
| field ` .hostPortRange` must specify the same number of… | validation | error | lima, port-forwarding, config-validation |
| field `vmOpts.vz.diskImageFormat` must be %#q or %#q, got… | validation | error | macos, vz, config-validation, disk-image |
| RunGUI is not supported for the given driver | exception | error | macos, vz, gui, config-validation |
| could not create %#q directory | console | error | filesystem, permissions, ssh-keys |