lima-vm/lima

Documented errors, page 3 of 5. Back to lima-vm/lima

Code / MessageTypeSeverityTags
failed to create a new rosetta directory share caching…
error_code error macos, vz-driver, rosetta
failed to create disk %#q
exception error disk, qemu-img, disk-creation, instance-storage
failed to protect instance %#q
console error instance, protect, filesystem
unsupported arch: %#q
validation error macos, vz, arch, config-validation
expected haCmd.Stdout to be *os.File, got %T
exception error internal-invariant, hostagent, unix
failed to unmarshal instance response
exception error json, external-driver, version-mismatch
instance or its configuration is not properly initialized
exception error configuration, nil-check, instance-state
unknown provision mode %#q
validation error provision, config-validation, cidata
vz driver requires macOS 13 or higher to run
exception critical macos, vz, version-check, startup
failed to bootstrap LaunchDaemon
console error macos, launchd, daemon, sudo
failed to convert %#q to %#q
exception error disk-image, qemu-img, conversion
invalid boot script filename %#q: must be in format 'boot.
validation error boot-scripts, filename-validation, driver, iso-generation
open disk
exception error apfs, filesystem, permissions, io
vz: CanRequestStop is not supported
exception error vz-driver, shutdown, macos, unsupported
daemon %#q is not available
panic critical network, daemon, panic, socket-vmnet, go
failed to create disk in %#q
console error disk, qemu-img, creation
another hostagent may already be running with pid
console error cli, process, pidfile, lima
failed to register instance %#q to start at login
console error autostart, linux, windows, filesystem
UDPFileConn connection closed
exception info network, udp, connection-closed, usernet
socket must be specified (limactl version mismatch?)
validation error cli, socket, version-mismatch, lima
failed to apply DNS configuration
exception error macos, cloud-init, dns, networksetup
failed to unmarshal line %#q
exception error guestagent, json, parsing, kubernetes
field ` .guestPort` must match field ` .guestPortRange[0]
validation error config-validation, port-forward, lima-yaml
sudo field must not contain newline characters
validation error validation, sudoers, security, cloud-init
failed to construct wsl boot.sh script
exception error wsl2, windows, template, provisioning
failed to create user %#q
exception error macos, cloud-init, user-creation, sysadminctl
failed to lock disk %#q
exception error krunkit, disks, lock, macos
failed to remove stale raw digest file
exception error go, filesystem, cache, permissions
field ` .hostPort` must match field ` .hostPortRange[0]
validation error lima, port-forwarding, config-validation
failed to read PID file %#q
error_code error network, pid-file, corrupt-file, daemon-startup
failed to run : %#q
console error ssh-keygen, exec, ssh-keys
failed to chown %#q for user %#q
exception error permissions, chown, macos, guestagent
failed to read boot scripts directory %#q
exception error cloud-init, macos, boot-scripts, filesystem
field `msize` has an invalid value
validation error lima, config-validation, ninep, size
failed to write sudoers file for user %#q
exception error sudoers, macos, guestagent, cloud-init
networks.yaml field `paths.
validation error config, networks-yaml, paths, macos
: %#q: unsupported arch: %#q
exception warning download, arch-mismatch, validation
field `provision[ ].permissions` can only be set when mode…
validation error lima, config-validation, provision, mode-mismatch
invalid plist: IOPlatformUUID not found in any child of…
exception error macos, ioreg, machine-id, plist
expected an absolute path, got a relative path: %#q
validation error mcp, path, validation, go
failed to calculate digest of raw image
exception error go, filesystem, digest, cache
failed to create disk %#q
error_code error macos, vz, disk-creation, io-error
failed to run : (stdout=%#q, stderr=%#q)
exception error sysctl, subprocess, unix, linux, macos
field ` .hostPort` must be 0 when field ` .hostSocket` is…
validation error lima, port-forwarding, config-validation
invalid digest in raw digest file
validation error downloader, cache, digest, corruption
failed to create new virtio block device config for extra…
error_code error vz-driver, virtio, virtualization-framework
failed to rename %#q to %#q
exception error filesystem, rename, disk-image
failed to run `wsl.exe --import
exception error wsl2, windows, wsl-exe, import
function takes at most 2 arguments
validation error templates, argument-validation, lima-yaml
sudoers file %#q is out of sync and must be regenerated
error_code error network, sudo, sudoers-file, socket-vmnet, homebrew, version-drift
cannot use `--sync` with a wsl2 instance, the host…
validation error cli, limactl, wsl2, sync, windows
failed to create a windows installation marker
exception error windows, filesystem, marker-file
cache did not contain %#q
exception error download, cache, digest
failed to create parent directory for path %#q
exception error cloud-init, macos, filesystem, permissions
template does not define param %#q
validation error cli, template, parameters, lima
unexpected symlink target for virtiofs mount source %#q…
exception error macos, cloud-init, symlink, virtiofs, state-conflict
failed to create host audio output stream
error_code error audio, vz-driver, virtualization-framework, macos
failed to determine if another hostagent is running
console error cli, process, pidfile, filesystem, lima
field `provision[ ].path` can only be set when mode is %#q…
validation error lima, config-validation, provision, mode-mismatch
invalid plist: top-level value is not a dict
exception error macos, plist, machine-id
socket path %#q is too long: >= UNIX_PATH_MAX=
console error unix-socket, path-length, ssh
rsync not found on host
exception error rsync, host-environment, path-lookup, dependency-missing
cannot delete disk %#q in use by instance %#q
console error disk, in-use, delete
freeport.VSock is not implemented for non-Windows hosts
exception error freeport, vsock, platform-support, windows
invalid plist: IORegistryEntryChildren not found or empty
exception error macos, plist, ioreg, machine-id
network mode %#q does not support specifying gateway
validation error network, cli, bridged
failed to create disk attachment for extra disk %#q
error_code error vz-driver, disk-attachment, virtualization-framework
field `provision[ ].script must be empty if playbook is set
validation error config-validation, provision, ansible, lima-yaml
inspect status command failed
exception error driver, subprocess, external-command
expected status %#q, got %#q (maybe use `limactl stop -f`?)
exception error instance-state, stop, lifecycle
failed to chmod %#q
exception error filesystem, permissions, chmod
failed to extract SSH local port from %#q
console warning lima, ssh, config-parsing
failed to run
error_code error network, sudo, permissions, socket-vmnet
failed to unlock for reuse in the same instance
console error disk, locking, flock
more than one (instance) host is involved in this command…
exception error scp, openssh-version, multi-host, compatibility
failed to download %#q
exception error download, network, http
failed to unmarshal xml
exception error macos, plist, xml, parsing
failed to write authorized_keys file for user %#q
exception error ssh, filesystem, macos, guestagent
host agent is running but driver is not
console error lima, hostagent, driver, pid-files, broken-instance
no template available
exception error autostart, configuration, template
timed out waiting for external driver to create socket file
exception error timeout, external-driver, socket, startup
failed to create Windows ISO entries
exception error windows, template, iso-generation
field `provision[ ].playbook` refers to an inaccessible…
validation error config-validation, provision, ansible, file-path
unexpected option %#q
validation error ssh, format, malformed-option
driver
exception error driver, screenshot, unsupported-feature
failed to detect the format of %#q
error_code error disk-image, vz-driver, format-detection
failed to run : (output= )
exception error ssh, shutdown, vz-driver, macos
failed to write file for path %#q
exception error macos, cloud-init, write-files, filesystem
failed to write rsync stats to pager
console warning pager, pipe, broken-pipe
invalid fstab entry: expected 6 fields, got
validation error cloud-init, fstab, validation, mount
unexpected port
exception error network, freeport, port-allocation
failed to create mount point %#q
exception error guestpatch, macos, filesystem, mount
failed to create temp file
console error macos, launchd, filesystem, temp-file
failed to run : ; stdout=%#q, stderr=%#q
exception error kubernetes, kubectl, guestagent, diagnostics
field User must not be `root`
validation error validation, user, cidata
unknown daemon type %#q
error_code error network, daemon, socket-vmnet, go
--verbatim cannot be used with any of --embed, --embed-all…
console error cli, template, flag-conflict, argument-validation
failed to create /etc/sudoers.d directory
exception error sudoers, filesystem, permissions, macos
passwordLessSudo error
error_code error network, sudo, permissions, socket-vmnet
path is required for write_files entry
validation error validation, cloud-init, yaml, guestagent